Jump to content
  • 0

Upgrade to 1.34 produces a Depreciated error on the top of the wiki page.


Question

I manually upgraded my wiki site from version 1.33 to version 1.34 and have been receiving the following message stuck at the top of my wiki. 

Depreciated : Use of $wgLocalInterwiki – use $wgLocalInterwikis instead was deprecated in MediaWiki 1.23.   
 

I am unable to find a solution to this issue and have searched the internet and Media Wiki. Below are the stats for my system. 

Product Version
MediaWiki 1.34.0
PHP 7.2.24 (cgi-fcgi)
MySQL 5.6.45
ICU  

Any assistance is appreciated. 

Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

As the error message says, you should use the variable called $wgLocalInterwikis (plural) instead of $wgLocalInterwiki (singular). You will most likely find the offending line of code in your wiki's settings file, LocalSettings.php.

Additionally, if and when you're seeing that (and/or similar notices) on top of your pages, you should verify that your LocalSettings.php file does not contain a line like ini_set( 'display_errors', 1 ); or ini_set( 'display_errors', true ); anywhere. That's what is enabling the displaying of PHP notices, warnings, errors, etc. and it is not recommended to show such messages on a production environment for a variety of reasons.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.