Jump to content
  • 0
Terrifiedham

Getting logged out after submitting a page Change

Question

Hello everyone,

Excuse me if this question has been asked before, but i don't know where else to ask, so far i haven't found a solution to my problem.

I have set up a mediawiki and often encounter the problem that users are getting logged out, most often after changing something on a page and submitting that change. (But sometimes that also happens when just browsing the wiki)

I have followed the steps for debugin login problem: https://www.mediawiki.org/wiki/Manual:How_to_debug/Login_problems

This unfortunately didn't help.

When recording the problem i've stumbled upon these lines on submitting that seemed odd to me, but since I am not an expert I don't know if they are relevant:

 

  1. Server:
    Apache
  2. Set-Cookie:
    UseCDNCache=false; expires=Wed, 26-Sep-2018 11:35:03 GMT; Max-Age=10; path=/; HttpOnly
  3. Set-Cookie:
    db10565584-pagename_mediawikiUserID=deleted; expires=Thu, 01-Jan-1970 00:00:01 GMT; Max-Age=0; path=/; HttpOnly
  4. Set-Cookie:
    db10565584-pagename_mediawiki_session=deleted; expires=Thu, 01-Jan-1970 00:00:01 GMT; Max-Age=0; path=/; HttpOnly
  5. Set-Cookie:
    db10565584-pagename_mediawiki_session=agqdcmcv6f2f156l2d801q4n7l7c58dd; path=/; HttpOnly
  6. Set-Cookie:
    UseDC=master; expires=Wed, 26-Sep-2018 11:35:03 GMT; Max-Age=10; path=/; HttpOnly
 
I am happy for any help and i am happy to provide more data if needed.
 
Best regards,
Lukas

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Can you provide some more info? The output you gave makes it seem like MediaWiki thinks the session being sent to it is not valid/expired and therefore spins up a new one. There are a wide variety of causes for this, none of which are particularly obvious or easy to spot. The following information would be very helpful in diagnosing this further:

1. Your phpinfo() for the server. Easiest way to get this is to run php -i > phpinfo.txt from the command line; the information will be stored in a new file named "phpinfo.txt" which you can then upload as an attachment.

2. Any session-related or cache-related settings in your LocalSettings.php (do not upload your entire LocalSettings.php as it contains private info such as database passwords and secret keys)

Share this post


Link to post
Share on other sites
  • 0

Hey Skizzerz, 

Thank you for the reply. I attached the phpinfo.txt document. 

Session related or cache-related settings as well as the extensions i installed will follow below (I figured that maybe an extension could cause these problems?):

 

# Protect against web entry
if ( !defined( 'MEDIAWIKI' ) ) {
    exit;
}

$wgExtendedLoginCookieExpiration= 0;


## Uncomment this to disable output compression
# $wgDisableOutputCompression = true;

## Shared memory settings
$wgMainCacheType    = CACHE_NONE;
$wgMemCachedServers = array();

## To enable image uploads, make sure the 'images' directory
## is writable, then set this to true:
$wgEnableUploads  = true;
#$wgUseImageMagick = true;
#$wgImageMagickConvertCommand = "/usr/bin/convert";

# InstantCommons allows wiki to use images from http://commons.wikimedia.org
$wgUseInstantCommons  = false;

## If you use ImageMagick (or any other shell command) on a
## Linux server, this will need to be set to the name of an
## available UTF-8 locale
$wgShellLocale = "en_US.utf8";

## If you want to use image uploads under safe mode,
## create the directories images/archive, images/thumb and
## images/temp, and make them all writable. Then uncomment
## this, if it's not already uncommented:
#$wgHashedUploadDirectory = false;

## Set $wgCacheDirectory to a writable directory on the web server
## to make your wiki go slightly faster. The directory should not
## be publically accessible from the web.
#$wgCacheDirectory = "$IP/cache";

# Site language code, should be one of the list in ./languages/Names.php
$wgLanguageCode = "de";


############## Handmade ################
# Specify who can edit: true means only logged in users may edit pages
$wgGroupPermissions['*'    ]['createaccount']   = false;
$wgGroupPermissions['*'    ]['edit']            = false;
$wgGroupPermissions['*'    ]['read']            = true; // Jeder darf die Seite lesen
$wgGroupPermissions['sysop']['createaccount']   = true;
$wgGroupPermissions['user' ]['edit']            = false;
$wgGroupPermissions['user' ]['read']            = true;
$wgGroupPermissions['user' ]['upload']          = false;
$wgGroupPermissions['user' ]['move-rootuserpages'] = false;
$wgGroupPermissions['user' ]['createpages']     = false;
$wgGroupPermissions['user' ]['reupload-shared'] = false;
$wgGroupPermissions['user' ]['reupload']        = false;
$wgGroupPermissions['user' ]['move']            = false;
$wgGroupPermissions['user' ]['writeapi']        = false;
$wgGroupPermissions['user' ]['move-subpages']   = false;
$wgGroupPermissions['user' ]['createpage']      = false;
$wgGroupPermissions['user' ]['purge']           = false;
$wgGroupPermissions['user' ]['movefile']        = false;
$wgGroupPermissions['user' ]['minoredit']       = false;
$wgGroupPermissions['user' ]['createtalk']      = false;


#Nutzergruppe Schreibende nutzer
$wgGroupPermissions['Editor']['read'] = true;
$wgGroupPermissions['Editor']['edit'] = true;
$wgGroupPermissions['Editor' ]['upload']          = true;
$wgGroupPermissions['Editor' ]['move-rootuserpages'] = true;
$wgGroupPermissions['Editor' ]['createpages']     = true;
$wgGroupPermissions['Editor' ]['reupload-shared'] = true;
$wgGroupPermissions['Editor' ]['reupload']        = true;
$wgGroupPermissions['Editor' ]['move']            = true;
$wgGroupPermissions['Editor' ]['writeapi']        = true;
$wgGroupPermissions['Editor' ]['move-subpages']   = true;
$wgGroupPermissions['Editor' ]['createpage']      = true;
$wgGroupPermissions['Editor' ]['purge']           = true;
$wgGroupPermissions['Editor' ]['movefile']        = true;
$wgGroupPermissions['Editor' ]['minoredit']       = true;
$wgGroupPermissions['Editor' ]['createtalk']      = true;

# Pages anonymous (not-logged-in) users may see
$wgWhitelistRead = array ("Spezial:Userlogin", "Wikipedia:Help");


###Widget Extension: (Reine HTMl seiten im Mediawiki erstellen)
###require_once "/extensions/Widgets/Widgets.php"; ###


$wgSessionCacheType = CACHE_DB;


$wgShowExceptionDetails = true;

$wgShowDBErrorBacktrace = true;


## Default skin: you can change the default skin. Use the internal symbolic
## names, ie 'cologneblue', 'monobook', 'vector':
$wgDefaultSkin = "Vector";


##IFrame extension. 
require_once "$IP/extensions/IframePage/IframePage.php";
 


##IDisplay extension
require_once "$IP/extensions/IDisplay/iDisplay.php";


##Skin MonoBook
wfLoadSkin( 'MonoBook' );

##ImageMap (Extension um Bilder verlinken zu können)
wfLoadExtension( 'ImageMap' );

##CategorySuggest Extension. (Vereinfacht die Benutzung von Kategorien)
require_once "$IP/extensions/CategorySuggest/CategorySuggest.php";

##Tabber Extension. (Allows tabs to add information to it)
wfLoadExtension( 'Tabber' );

##WikiEditor (für eine einfachere bearbeitung des wikis)
wfLoadExtension( 'WikiEditor' );

##Enables the Link Titles Extension  and Configurations for it below the first line##
wfLoadExtension( 'LinkTitles' );
$wgLinkTitlesParseOnEdit = true;  ##enables Link Titles on every page
$wgLinkTitlesSmartMode = true; ##enables Smart Linking
$wgLinkTitlesParseHeadings = false; ##This disables links for headings


##PDFBOOK extension. (Erlaubt das extrahieren von PDFS von einzelnen wiki seiten.)
wfLoadExtension( 'PdfBook' );


##Maybe a fix for the cookie problem?
$wgCookieSecure = false;

 

 

 

phpinfo.txt

Share this post


Link to post
Share on other sites
  • 0

I'm not sure if this will actually help or not, but try adding the following into your LocalSettings.php:

$wgTmpDirectory = '/is/htdocs/user_tmp/wp10565584_JYRT1G91HG';

 

If that doesn't help, the next step is to enable debug logging for sessions to get greater insight into what's going on behind-the-scenes. See this article for information on how to set that up. To avoid tons of noise in the file, you may want to only enable logging for the session debug log group.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.