Jump to content
  • 0
fanatikvoice

Extension:Translate - cant translate page

Question

6 answers to this question

Recommended Posts

  • 0

You need to mark the page for translation before you can translate it. Are you saying that you've clicked "Mark this page for translation" but it did nothing? What happens when you click that link, any error messages or other indication of things happening?

Share this post


Link to post
Share on other sites
  • 0
18 hours ago, Skizzerz said:

You need to mark the page for translation before you can translate it. Are you saying that you've clicked "Mark this page for translation" but it did nothing? What happens when you click that link, any error messages or other indication of things happening?

No, no message error, i click button "Mark this page for translation" -> add markup <translate>  -> Save -> its no link "Translate this page"

Share this post


Link to post
Share on other sites
  • 0
On ‎12‎/‎21‎/‎2018 at 8:40 AM, fanatikvoice said:

No, no message error, i click button "Mark this page for translation" -> add markup <translate>  -> Save -> its no link "Translate this page"

That's very odd. Can you provide some additional information about your wiki? You can find all of this information on the Special:Version page on your wiki.

  • MediaWiki version
  • Translate version
  • PHP version

Share this post


Link to post
Share on other sites
  • 0
18 hours ago, Skizzerz said:

That's very odd. Can you provide some additional information about your wiki? You can find all of this information on the Special:Version page on your wiki.

  • MediaWiki version
  • Translate version
  • PHP version

 

MediaWiki 1.31.1
PHP 7.0.27-0+deb9u1 (cgi-fcgi)
MariaDB 10.1.26-MariaDB-0+deb9u1
ICU 57.1
Translate 2018-04-10 (950ea85)21:49, 7 august 2018

 

Share this post


Link to post
Share on other sites
  • 0

Can you try upgrading your version of Translate? The latest version of the language bundle (2018.10) is compatible with MediaWiki 1.31 and I see that there were a few bug fixes for the Translate extension; it is possible that your issue was already fixed. The best way to update the extensions is as follows:

  1. Download the latest bundle.
  2. Archive the existing versions you have of those extensions in your extensions folder. A decent way to do this on a temporary basis is to rename the directories. For example, rename the "Translate" directory in your extensions directory to "Translate-old".
  3. Upload the bundle to your server and extract it into the extensions directory. This will create a brand-new "Translate" directory, among others.
    • The reason why you should rename or delete the old version first is because there are sometimes issues with extracting the new version on top of the old version -- if a file was deleted between the old and new version, the old file will remain in-place and could cause issues with functionality or expose security risks. By renaming or deleting the old version first, you avoid these issues.
  4. Run the update.php maintenance script to perform any relevant database updates, or use the web installer to update if you don't have SSH access. You should always run the updater after updating MediaWiki or any extensions.

After doing that, try it again. If it still doesn't work, check your error logs to see if anything is showing up there (and configure PHP to log errors if it isn't currently doing that).

Share this post


Link to post
Share on other sites
  • 0

I download Translate for Bundle. I not download from extension page Translate.

No errros log and dispalay error on site. Extension work, no work is good.

Edited by fanatikvoice (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.